Tech Blog

The Seven Monkeys: Wormable Vulnerabilities vs. Tanium

Microsoft’s latest vulnerability disclosure release contains updates for 93 CVEs, highlighting seven as important/critical and now referred to as the ‘Seven Monkeys’. Four of these (CVE-2019-1181, CVE-2019-1182, CVE-2019-1222, CVE-2019-1226) are described as wormable. This means they can be exploited to spread malware from one vulnerable computer to another without any user action, much in the same way WannaCry and NotPetya outbreaks did in 2017.

What To Do As A Tanium Customer

Improved IT hygiene can prevent incidents stemming from these vulnerabilities. We urge you to use Tanium Comply to see if your endpoints are vulnerable and use Tanium Patch to patch them immediately. Tanium Comply measures exposure to these vulnerabilities using the Tanium Vulnerability Library feed.

Highlighted in red in the graphic above is the ability to link to Tanium Patch. This provides the ability for Tanium to instantly deploy the necessary patches. Tanium will track the progress of installation, including notifying the end user of a required reboot, to fully monitoring the closure of the vulnerability.

In this short video, we demonstrate a “find it and fix it” workflow, that starts with finding a vulnerability with Tanium Comply and then pivots smoothly to Tanium Patch to remediate it.

For more information and support, reach out to your Technical Account Manager or your Tanium Community.

Not yet a Tanium customer? Get started by contacting [email protected] today.

Featured Webinars

Upcoming Events

Contact Sales


Press Inquiries


Contact Us


Thank you for contacting us


Back to the Tanium Home Page